BTRIPP (btripp) wrote,
BTRIPP
btripp

Ah ... so frustrating ...

OK, so I sort of abuse my computer ... I will, at times, have as many as sixty tabs open in a couple of FireFox windows, and a dozen other programs running. I've recently been moving Twitter (yes, I still use the web version) over to Chrome, just so I can keep better track of it.

However, recently (and I don't have more than a couple of dozen tabs open today), Chrome has just been "giving up" on loading stuff. I'll click on a link in a Tweet and a tab will open and the spinny thing will spin, but after a while, I'll see this:



... and almost always for sites I know damn well are up. What's doubly aggravating about this is that when I go back to the tab and hit the "reload" button, the page pops right up! Now, if I was seeing this on one out of a dozen links, it would be irritating enough, but I'm seeing it like one in three times. Not happy. I also just read a thing which was benchmarking the browsers, and it said that Chrome was currently the fastest ... don't know what to think of that in terms of what I've been experiencing!

I suppose if this wasn't quite so declarative ... "DNS error - cannot find server" / "This link appears to be broken." ... for things that I know are working it wouldn't be so objectionable, but it's almost into a MicroSoft level of "it can't be US, so it must be YOU" haughtiness.

Anyway, this was bugging me enough that I'd figure I'd share.


Visit the BTRIPP home page!



Subscribe
  • Post a new comment

    Error

    default userpic

    Your reply will be screened

    Your IP address will be recorded 

    When you submit the form an invisible reCAPTCHA check will be performed.
    You must follow the Privacy Policy and Google Terms of use.
  • 6 comments